Home
Nosotros
Servicios
Portafolio
Hosting
Blog
Contáctanos

Un bug en Linux de hace 12 años permite obtener acceso root en casi cualquier distro, y ya lo han explotado

Investigadores de seguridad de Qualys han descubierto una vulnerabilidad grave en Linux que afecta a la mayoría de distribuciones. Se trata de un fallo de corrupción de memoria en PolKit, es un componente para controlar los privilegios de todo el sistema que viene instalado por defecto en la mayoría de distros y otros sistemas operativos UNIX-like.

La vulnerabilidad, que ha sido nombrada “PwnKit“, puede ser explotada fácilmente para permitir a cualquier usuario sin privilegios obtener privilegios totales de root en un host vulnerable.

Tras tres horas de ser publicado, PwnKit ya tenía un exploit

Linux Pwnkit

Tras la publicación de los detalles técnicos por parte de Qualys, en menos de tres horas ya había un exploit público fácil de reproducir. Algo que han comprobado desde BleepingComputer, pudiendo obtener privilegios de root en el sistema en todos sus intentos.

PwnKit, identificado como CVE-2021-4034, es un fallo que tiene su origen hace más de 12 años, y parece proceder del primer commit publicado de pkexec. Esto quiere decir que todas las versiones de Polkit se encuentran afectadas.

Los investigadores comprobaron que PwnKit puede ser usado para elevar privilegios en instalaciones por defecto de Ubuntu, Debian, Fedora y CentOS

Los investigadores lograron utilizar el programa pkexec para obtener privilegios de root en instalaciones por defecto de Ubuntu, Debian, Fedora, y CentOS, pero advierten que PwnKit es probablemente explotable en cualquier otra distribución Linux.

Qualys informó el problema de seguridad de manera responsable el 18 de noviembre de 2021 y esperó a que un parche estuviera disponible antes de publicarlo. La recomendación para todos los administradores de sistema es dar prioridad a la aplicación de los parches que los autores de Polkit han publicado en GitLab.

Red Hat publicó una actualización de seguridad para polkit, y Canonical ya publicó parches para Ubuntu en las versiones 14.04 y 16.04 ESM, además de para sus versiones más recientes con soporte, como Ubuntu 18.04, 20.04, y 21.04. Solo hace falta actualizar el sistema y reiniciar para protegerse de la vulnerabilidad.

Este es el tercer bug descubierto en Linux en el último año que permite obtener privilegios de root

Este es el tercer bug importante que permite obtener privilegios de root que descubre Qualys en los últimos meses. El anterior, ‘Sequoia’, era una vulnerabilidad del kernel Linux que afecta a la mayoría de sus instalaciones y que se había incorporado al kernel hace más de siete años. Antes de ese, encontraron un fallo crítico en Sudo que estaba ahí desde 2011.


La noticia

Un bug en Linux de hace 12 años permite obtener acceso root en casi cualquier distro, y ya lo han explotado

fue publicada originalmente en

Genbeta

por
Gabriela González

.

Iniciar chat
1
💬 Necesitas ayuda?
JAHNISSI PERU
Hola 👋
Podemos ayudarte?